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The Balance Sheet lists all of the assets, liabilities, and equity of an entity for 
a specific date, usually at the end of a month or a year. The Income 
Statement is a summary of the revenues and expenses of the business year 
for a specific period of time. This report shows the income statement for YTD 
and the month for a specified date.

Introduction
The following tutorial assumes that you have completed the “Quick start for 
new users” tutorial in the Crystal Reports XI User’s Guide, which is located in 
the Docs folder of your product distribution.

Creating the report
On the Start Page in Crystal Reports, click Blank Report.
The Database Expert dialog box appears.
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Selecting a database to use
When you create a report, the first thing that you must do is to select a 
database for the report to use.

X To select a database
1. In the Database Expert dialog box, expand the Create New Connection 

folder.
2. Double-click ODBC (RDO).

The ODBC (RDO) dialog box appears and displays a list of data sources.

3. From the list, select Xtreme Sample Database 11.5, and click Finish.

The Database Expert displays a list of available tables from the Xtreme 
Sample Database.

4. Select the Account, Account Type, and Journal Entry tables, and click > 
to add them to the Selected Tables list.

Tip:  You can use CTRL+click to select multiple tables simultaneously.
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5. Click OK.

The Links tab is displayed.

6. Verify that the links between the tables are consistent with what is displayed 
in the screenshot above. If necessary, create the appropriate links by 
dragging fields from one table to corresponding fields in another table.

Note:  Ensure that the following links exist:
• Account.Account Type ID to Account Type.Account Type ID
• Account.Account Number to Journal Entry.Account Number

7. Click OK.
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Setting up the report date
X To set up the report date
1. Click Field Explorer.
2. In the Field Explorer, right-click Parameter Fields, and click New.

The Create New Parameter dialog box appears.

3. In the Name field, type End Date.
4. From the Type list, select Date Time, and click OK.

Setting up selection criteria
A lselection criteria restricts the range of journal entries that are included in 
the report. For this report, you need to restrict the journal entries to those from 
dates that are less than the value of the End Date parameter.
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X To create selection criteria
1. Click Select Expert.

The Choose Field dialog box appears.

2. Expand the Journal_Entry table, and select Date.
3. Click OK.

The Select Expert dialog box appears.

4. Ensure that the Journal_Entry.Date tab is selected, and from the list, 
choose is less than or equal to.

5. From the second list that appears, select End Date.
6. To restrict journal entries, type the following formula in the text area:

{Journal_Entry.Date} <= {?End Date} and
{Account_Type.Account Type} in 

("Equity","Liability","Asset")

7. Click OK.
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Setting up groupings
For this report, you must group records based on Account Type and Account 
Name.

X To create report groupings
1. Click Group Expert.

The Group Expert dialog box appears.

2. In the Available Fields area, expand the Account_Type table, select 
Account Type, and click >.

3. Click Options....
The Change Group Options dialog box appears.
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4. From the second list, select in specified order.
5. From the Named Group: list, select the following values in order:

• Revenue
• Expense

6. Click OK.
7. In the Available Fields area, expand the Account table, select Account 

Name, and click >.
The dialog box displays your groupings.

8. Click OK.

Creating formula fields
The Combination Balance Sheet and Income Statement uses several formula 
fields. You must create the necessary fields and add them to the report.

X To create formula fields
1. Click Field Explorer.
2. In the Field Explorer, right-click Formula Fields, and click New.
3. In the Formula Name dialog box, type YTD_balance, and click OK.
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The Formula Workshop appears.

4. Type the following formula:
if {Journal_Entry.Debit Or Credit} = 'Credit' then
    {Journal_Entry.Amount} * -1
else 
    {Journal_Entry.Amount}

This formula returns the amounts of the journal entries. Because all of the 
values in the journal entries are positive, you need to reverse the sign of 
all the credit amounts to distinguish between debits and credits.

5. Click Check to verify that the syntax of the formula is correct.
6. Click Save and close.
7. Repeat steps 2 through 6 to create the following formula fields:

• YTD_balance_check: This formula field is used to calculate the 
balance by subtracting the total liabilities, equity, and current 
earnings from the total assets.
{@YTD_total_L_and_E_balance_and_current_earnings} + 
Sum ({@YTD_total_assets})
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• YTD_liability_and_equity_balance: This formula field returns the 
amount of the journal entry if the account type is a liability or an 
equity. Otherwise, ‘0’ is returned. This field is used to calculate the 
totals for liabilities and equity. Because all of the values in the journal 
entries are positive, you need to reverse the sign for all of the credit 
amounts to distinguish between debits and credits.
if {Account_Type.Account Type} in 

['Equity','Liability'] then
(
if {Journal_Entry.Debit Or Credit} = 'Credit' then
{Journal_Entry.Amount} * -1
else
{Journal_Entry.Amount}
)

• YTD_net_income: This formula field returns the amount of the 
journal entry if the account type is a revenue or an expense. 
Otherwise, ‘0’ is returned. This field is used to calculate the net 
income. Because all of the values in the journal entries are positive, 
you need to reverse the sign for all of the credits amount to 
distinguish between debits and credits.
if {Account_Type.Account Type} in 

['Revenue','Expense'] then
(
if {Journal_Entry.Debit Or Credit} = 'Credit' then
{Journal_Entry.Amount} * -1
else
{Journal_Entry.Amount}
)

• YTD_total_assets: This formula field returns the amount of the 
journal entry if the account type is an asset. Otherwise, ‘0’ is 
returned. This field is used to calculate the total assets. Because all 
of the values in the journal entries are positive, you need to reverse 
the sign for all of the credit amounts to distinguish between debits 
and credits.
if {Account_Type.Account Type} = 'Asset' then
(
if {Journal_Entry.Debit Or Credit} = 'Credit' then
{Journal_Entry.Amount} * -1
else
{Journal_Entry.Amount}
)
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• YTD_total_L_and_E_balance_and_current_earnings: This 
formula field calculates the total liabilities, equity, and current 
earnings by adding the totals.
Sum ({@YTD_liability_and_equity_ balance}) +
Sum ({@YTD_net_income})

• type_total_heading: This formula field sets the value of the Account 
Type field in the Account Type table to Total Assets for asset 
accounts, Total Liabilities for liability accounts, and Total Equity for 
equity accounts.
if {Account_Type.Account Type} = 'Asset' then
"Total Assets"
else if {Account_Type.Account Type} = 'Liability' then
"Total Liabilities"
else
"Total Equity"

Adding fields to the report
After you create the formula fields, you can begin to add fields to the report.

X To add fields to the report
1. From the Field Explorer, drag the YTD_balance field to the right end of 

the Details section.
2. Drag the YTD_liability_and_equity_ balance field to the left side 

of the YTD_balance field in the Details section.
3. Drag the YTD_total_assets field to the left side of the 

YTD_liability_and_equity_ balance field in the Details section.
4. Drag the YTD_net_income field to the left side of the 

YTD_total_assets field in the Details section.
5. Right-click the each of the headings that were automatically created in 

the Page Header section, and click Delete.
The report should now look similar to the following screenshot:
Crystal Reports XI Release 2: Financial Report Tutorials 11



Combination Balance Sheet and Income Statement
Creating the report
6. Right-click the YTD_balance field, and choose Insert > Summary.
The Insert Summary dialog box appears.

7. For the Summary Location, select Group #2, and click OK.
8. Right-click the YTD_balance field again, and choose Insert > Summary.
9. For the Summary Location, select Group #1, and click OK.
10. Right-click the YTD_net_income field, and choose Insert > Summary.
11. For the Summary Location, select Grand Total (Report Footer).
12. Right-click the YTD_total_assets field, and choose Insert > Summary.
13. For the Summary Location, select Grand Total (Report Footer).
14. Right-click the YTD_liability_and_equity_balance field, and 

choose Insert > Summary.
15. For the Summary Location, select Grand Total (Report Footer).
16. Expand the Report Footer section to be approximately 1.5 inches.
17. In the Report Footer section, position the sum of YTD_net_income field 

below the YTD column. Apply bold formatting to the field, and add a 
single top border.

18. Drag the YTD_total_L_and_E_balance_and_current_earnings 
field to the Report Footer section, and center it under the sum of the 
YTD_net_income field. Apply bold formatting to the field, and add a 
single top border.

19. Drag the YTD_balance_check field to the Report Footer section under 
the YTD_total_L_and_E_balance_and_current_earnings field. 
Apply bold formatting to the field, and add a single top border and a 
double bottom border.

20. Right-click Report Footer, and click Suppress (No Drill-Down).
21. Right-click Group Header #2, and click Hide (Drill-Down OK).
22. Right-click Group Footer #2, and click Hide (Drill-Down OK).
23. Right-click Details, and click Suppress (No Drill-Down).
After you add the appropriate fields and create the necessary summary fields, 
you can apply conditional formatting.
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X To apply conditional formatting
1. Click Section Expert.

The Section Expert dialog box appears.

2. In the Sections: area, select Group Footer #1.
3. Select the Suppress (No Drill-Down) option, and click the Formula 

button next to the option.
The Formula Workshop appears.
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4. Type the following formula, and then click Save and close:
{Account_Type.Account Type} in ['Revenue','Expense']

5. Click OK.
6. Repeat steps 1 through 5 for Group Footer #1.

The report should now look similar to the following screenshot:

7. Create a text field in the Report Footer section, and center it vertically 
with the sum of the YTD_net_income field. In the text field type + 
Current Earnings (Net Income), and apply bold formatting to the 
text.

8. Create a text field in the Report Footer section, and center it vertically 
with the YTD_total_L_and_E_balance_and_current_earnings field. 
In the text field type Total Liabilities and Equity, and apply bold 
formatting to the text.

9. Create a text field in the Report Footer section, and center it vertically 
with the YTD_balance_check field. In the text field type Balance 
Check, and apply bold formatting to the text.

10. Create a text field in the Page Header section, and place it above the 
YTD columns. In the text field, type YTD. Center the text, apply bold 
formatting, and add a single bottom border.
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Reviewing your work
To see how the report looks with the fields in place, click Print Preview to 
activate the Preview tab.
The report appears in preview mode.

After you finish reviewing the report, click the Design tab to correct any 
mistakes.

Completing the Balance Sheet
Now that the report has been built to display the correct data, you can add the 
report title, the report date, and the company logo.

X To add a report title and report date
1. Expand the Page Header section to be approximately 2 inches in height.
2. Create a new text field centered in the Page Header section.
3. Enter the text Xtreme Mountain Bikes in the new text field.
4. Create another text field with the text Balance Sheet. Place this text 

field in the Page Header section directly beneath the Xtreme Mountain 
Bikes text field.

5. Create another text field and add it to the Page Header section directly 
beneath the Balance Sheet text field. In this text field type For the 
months ending.
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6. Drag the End Date parameter field anywhere into the Page Header 
section.

7. Right click the End Date field and click Format Field.
The Format Editor is shown.

8. Select 03/01/1999 as the Date and Time format and click OK.
9. Drag the End Date field into the text field with the text For the months 

ending.

X To add a company logo to the report
1. Click Insert Picture.
2. Choose a bitmap (.bmp) logo file, and click Open.
3. Position the object frame in the upper right-hand corner of the Report 

Header (RH) section of the report.
4. Click the Preview tab.

Note:  The report should now look similar to the following screenshot:

Creating a subreport
After you finish the Balance Sheet section of the Consolidated Balance Sheet 
and Income Statement report, the nest step is to create the Income Statement 
section. For this report, you must create the Income Statement section as a 
subreport to the Balance Sheet.

X To create a subreport
1. On the Insert menu, click Subreport.
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The Insert Subreport dialog box appears.

2. In the New report name field, type Income Summary.
3. Select the On-demand subreport (similar to a hyperlink) option to 

ensure that the report does not run on the balance sheet.
4. Click Report Wizard....

The Standard Report Creation Wizard dialog box appears.
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5. From the Xtreme Sample Database 11.5 connection, select the Account, 
Account Type, and Journal Entry tables, and click > to add them to the 
Selected Tables list.

Tip:  You can use CTRL+click to select multiple tables simultaneously.
6. Click Next.

The Links tab is displayed.

7. Verify that the links between the tables are consistent with what is displayed 
in the screenshot above. If necessary, create the appropriate links by 
dragging fields from one table to corresponding fields in another table.

Note:  Ensure that the following links exist:
• Account.Account Type ID to Account Type.Account Type ID
• Account.Account Number to Journal Entry.Account Number

8. Click Finish.

9. In the Insert Subreport dialog box, click the Link tab.
10. In the Available Fields area, select the End Date parameter and click >.
11. Ensure that the Select data in subreport based on field: option is 

selected and that the list underneath it has the value 
Journal_Entry.Date.

12. Click OK.
A link to the subreport is linked to your mouse cursor.
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13. Place the link in the Report Footer section.
14. Right-click the subreport link, and select Edit Subreport....

A new design view where you can edit the subreport appears.

Creating the Income Statement
After you insert the subreport into the main report, you can create the Income 
Statement.

Adding additional tables to the Income Statement
X To add tables
1. Click Database Expert.

The Database Expert dialog box appears.
2. Select the Account Heading and Journal Entry Type tables, and click > 

to add them to the Selected Tables list.

Tip:  You can use CTRL+click to select multiple tables simultaneously.
3. Click OK.

The Links tab is displayed.
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4. Verify that the links between the tables are consistent with what is displayed 
in the screenshot above. If necessary, create the appropriate links by 
dragging fields from one table to corresponding fields in another table.

Note:  Ensure that the following links exist:
• Account.Account Type ID to Account Type.Account Type ID
• Account.Account Number to Journal Entry.Account Number
• Account.Account Heading Number to Account 

Heading.Account Heading Number

• Journal Entry.Journal Entry Type ID to Journal Entry 
Type.Journal Entry Type ID

5. Click OK.

Setting up selection criteria
A selection criteria restricts the range of journal entries that are included in 
the report. For this report, you need to restrict the journal entries to those that 
fall between January 1st of the End Date year (for YTD calculations) and the 
End Date parameter. For example, if the End Date parameter has a value of 
November 14, 2005, then the journal entries are restricted to those between 
January 1, 2005 and November 14, 2005.
In addition to restricting journal entries based on dates, you need to restrict 
journal entries based on type. On January 1st of each year, the process of 
closing accounts is performed. These closing entries include the closure of all 
revenue and expense accounts and adjustments to Retained Earnings to 
reflect a net gain or net loss. Therefore, closing entries must not be included 
in the calculations; such entries must be restricted. You also need to restrict 
journal entries to display only Revenue and Expense accounts.
X To create selection criteria
1. Click Select Expert.

The Choose Field dialog is shown.
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2. Expand the Journal_Entry table, and select Date.
3. Click OK.

The Select Expert dialog box appears.

4. Ensure that the Journal Entry.Date tab is selected, and from the list, 
choose formula:.

5. To restrict journal entries, type the following formula in the text area:
{Journal_Entry.Date} <= {?Pm-?End Date} and
{Journal_Entry.Date} >= dateserial(year({?Pm-?End 

Date}),1,1)

Note:  
• dateserial is an SQL function that accepts three parameters (year, 

month, and day) and returns a valid date.
• year is an SQL function that accepts a date and returns only the 

year portion.
6. Now that the journal entry dates are restricted by the formula, you need 

to add criteria to restrict the closing entries. In the Select Expert dialog 
box, click the <New> tab.

7. In the Choose Field dialog box, expand the Journal_Entry_Type table, 
and select Journal Entry Type.

8. Click OK.
9. Ensure that the Journal_Entry_Type.Journal Entry Type tab is selected, 

and from the list, choose is not equal to.
10. From the list that appears, select closing entries.
11. Click the <New> tab.
12. In the Choose Field dialog box, expand the Account_Type table, and 

select Account Type.
13. Click OK.
14. Ensure that the Account_Type.Account Type tab is selected, and from 

the list, choose is one of.
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15. From the list that appears, select Revenue and Expense.
16. Click OK.

Setting up groupings
For this report, you must group records based on Account Type, Account 
Heading Name, and Account Name.

X To create report groupings
1. Click Group Expert.

The Group Expert dialog box appears.

2. In the Available Fields area, expand the Account_Type table, select the 
Account Type field, and click >.

3. Click Options....
The Change Group Options dialog box appears.
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4. From the second list, select in specified order.
5. From the Named Group: list, select the following values in order:

• Revenue
• Expense

6. Click OK.
7. Expand the Account table, select Account Name, and click > to create a 

second group.
8. Expand the Account_Heading table, select Account Heading Name, 

and click > to create a third group.
The dialog box displays your groupings.

9. Click OK.

Creating formula fields
The Combination Balance Sheet and Income Statement report uses several 
formula fields. You must create the necessary fields and add them to the 
report.

X To create formula fields
1. Click Field Explorer.
2. In the Field Explorer, right-click Formula Fields, and click New.
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3. In the Formula Name dialog box, type month, and click OK.
The Formula Workshop appears.

4. Type the following formula:
MonthName(month({?Pm-?End Date}))

This formula field displays the textual representation of the End Date 
month.

5. Click Check to verify that the syntax of the formula is correct.
6. Click Save and close.
7. Repeat steps 2 through 6 to create the following formula fields:

• month_balance: This formula field returns the amount of the journal 
entries for the reporting month. Otherwise, ‘0’ is returned. Because 
all of the values in the journal entries are positive, you need to 
reverse the sign for all of the credit amounts to distinguish between 
debits and credits.
if month({Journal_Entry.Date}) = month({?Pm-?End 

Date}) then
if {Journal_Entry.Debit Or Credit} = 'Credit' then
{Journal_Entry.Amount} * -1
else
{Journal_Entry.Amount}
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• type_heading: This formula field displays the account type as Net 
Sales for revenue accounts or Total Expenses for expense accounts.
if GroupName ({Account_Type.Account Type})= 'Revenue' 

then
"Net Sales"
else
"Total Expenses"

• YTD_balance: This formula field returns the amount of the journal 
entries. The same calculations for debits and credits are used.
if {Journal_Entry.Debit Or Credit} = 'Credit' then
{Journal_Entry.Amount} * -1
else
{Journal_Entry.Amount}

Adding fields to the report
After you create the formula fields, you can begin to add fields to the report.
Note:  Before you add the fields, adjust the page setup of the report to use 
legal size paper with a landscape orientation. This arrangement is required to 
accommodate the fields in the report.

X To add fields to the report
1. From the Field Explorer, drag the YTD_balance field to the Details 

section, and align the right edge of the field with the 8 inch mark.
2. Drag the month_balance field to the Details section, and align the right 

edge of the field with the 4.75 inch mark.
3. Right-click all of the headings that were automatically created in the Page 

Header section, and click Delete.
The report should now look similar to the following screenshot:
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4. Right-click the month_balance field, and choose Insert > Summary.
The Insert Summary dialog box appears.

5. For the Summary Location, select Group #1, and click OK.
6. Apply a single top border to the Group #1 summary field.
7. Right-click the month_balance field, and choose Insert > Summary.
8. For the Summary Location, select Group #3, and click OK.
9. Right-click the month_balance field, and choose Insert > Summary.
10. For the Summary Location, select Grand Total (Report Footer), and 

click OK.
11. Apply a single top border and a double bottom border to the Grand Total 

summary.
12. Repeat steps 4 through 11 for the YTD_balance field.

The report should now look similar to the following screenshot:
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13. Right-click Group Header #3, and click Suppress (No Drill-Down).
14. Right-click Details, and click Suppress (No Drill-Down).
15. Right-click Group Footer #2, and click Suppress (No Drill-Down).
16. Move the Group #3 Name field from the Group Header #3 section to the 

Group Footer #3 section.
The report should now look similar to the following screenshot:

After you add the appropriate fields to the data in the report, you can create 
create column headings.

X To create column headings
1. From the Field Explorer, drag the @month formula field to the Page 

Header section. Resize the heading so that it spans the three month 
bound columns.

2. For the second column heading, add a text field above the YTD bound 
columns in the Page Header section, and type YTD.

3. Format the two column headings fields to display bold text, aligned to the 
center with a single line bottom border.

4. Drag the type_heading field to the Group Footer #1 section, and align 
it horizontally with the Group #2 Name field.

5. Create a new text field in the Report Footer section aligned horizontally 
with the Group #1 Name. In this text field type “Net Income”.
The report should now look similar to the following screenshot:
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Reviewing your work
To see how the report looks with the fields in place, click Print Preview to 
activate the Preview tab.
The report appears in preview mode.

Note:  Revenue accounts that are also credit accounts may display negative 
amounts. To display positive values, you need to apply conditional formatting 
on the sum fields for both the month_balance and the YTD_balance fields.

X To apply conditional formatting
1. Right-click sum of the month_balance field, and select Format Field.
2. On the Number tab, click Customize....
3. Select the Reverse Sign for Display option, and click the Formula 

button beside the option.
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The Formula Workshop appears.

4. Type the following formula, and then click Save and close:
{Account_Type.Account Type} = 'Revenue'

5.
6. In the Group Footer #1 section, right-click the sum of the 

month_balance field, and select Format Field.
7. On the Number tab, click Customize....
8. Select the Reverse Sign for Display option, and click the Formula 

button beside the option.
9. In the Formula Workshop, type the following formula, and then click Save 

and close:
{Account_Type.Account Type} = 'Revenue'

10. In the Group Footer #1 section, right-click the sum of the 
month_balance field, and select Format Field.

11. On the Number tab, click Customize....
12. Select the Reverse Sign for Display option, and click the Formula 

button beside the option.
13. Click OK.
14. Repeat steps 1 to 12 to apply conditional formatting to all of the other 

columns.
After you finish reviewing the report, click the Design tab to correct any 
mistakes.
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Completing the report
Now that the report has been built to display the correct data, you can add the 
report title, the report date, and the company logo.

X To add a report title and report date
1. Expand the Page Header section to be approximately 2 inches in height.
2. Create a new text field at the center of the Page Header section, and 

type Xtreme Mountain Bikes.
3. Create another text field directly underneath the Xtreme Mountain Bikes 

text field, and type Income Statement.
4. Create another text field directly underneath the Income Statement text 

field, and type For the months ending.
5. Drag the End Date parameter field to anywhere in the Page Header 

section.
6. Right-click the End Date field, and click Format Field.

The Format Editor appears.
7. Select 03/01/1999 as the Date and Time format, and click OK.
8. Drag the End Date field into the text field that contains For the months 

ending.

X To add a company logo to the report
1. Click Insert Picture.
2. Choose a bitmap (.bmp) logo file, and click Open.
3. Position the object frame in the upper right-hand corner of the Report 

Header (RH) section of the report.
4. Click the Preview tab.
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The report should now look similar to the following screenshot:

Saving the report
X To save the report
1. Click Save.

Because this is the first time that you are saving the report, the Save As 
dialog box appears and displays the location where the file will be saved.

2. In the File name field, type BalanceSheetAndIncomeStatment.rpt, 
and click Save.

The report is saved to the location that you chose.
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Saving the report
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